playSMS version 0.9.8 has been released

Just released. It has lots of bug fixes and several interesting enhancements, including some major changes.

Some of the highlights:

  • Using PHP session :)
  • Installer script for Ubuntu users
  • Web Services to respond in JSON and XML format
  • Web Services to authenticate using a token instead of username and password, with IP limit
  • Search boxes
  • Export SMSes, save it to a CSV file
  • Reply from receiver straight to user’s Inbox (no need to use @user)
  • Broadcast from mobile using #<phonebook group> instead of BC <phonebook group>
    • To all #IT group members, please come to meeting room
    • Hi #GOLD #SILVER members, you can get more bonus by purchasing more!

Read full changelog here.

Grab it from SourceForge: download




  1. Anton,

    Thank you for this great product! I have been using it for a few versions now, and haven’t had any problems with the upgrades till now. I noticed that the sms_command execution files were no longer in /var/www/html/playsms/bin but in /var/lib/playsms/sms_command/1/ so I copied over my executables to this new location. I have also updated my scripts to use the new hash tokens and not the login credentials. When I execute the script from the command line, it works perfectly. However, I can’t get it to execute from playsms. What i mean, is that playsms shows that the keyword sms was “handled” but the script itself is not executed. in the log file, /var/log/playsms/playsms.log I don’t see any mention of the sms_command keyword when it receives the sms … where should i look to next to find out why it isn’t executing the file?




    1. In the web interface it is showing the path as /var/lib/playsms/sms_command/1/ but when i changed the log level to 3 (for debug) i found that it was looking for the file in /var/lib/playsms/sms_command and not in the final 1 directory.

      could that 1 be a typo that needs to be removed? i’ve copied my files in the sms_command directory and its now working. :)




  2. Hi Anton,

    I have a website thats use playSMS 0.97 with Webservices and I try to upgrade this service to playSMS 0.98.

    I upgrade works as well, but the webservices stops to work. When I try to call the webservice function, playsms raises a authentication error ERR:100 – Autenthication Failed.

    Do you know any solution or suggestion about this issue?

    Thanks a lot for your great service.

    Doug D. Moraes



  3. Hi there!

    PlaySms is a great software and I enjoy it every day. Thank you for the job! I hope you will continue to improve it. : :smile:

    I use smstools to send sms, procmail and bash scripts to route email to sms in both ways (incoming and outgoing). I used smstools directly and it worked well.

    Yesterday, I changed my mind and now I use playsms webservices to send SMS.
    I’ve updated some php files in your code to deal with users and token.

    Now, any user can send an email to my email2sms gateway. Email is processed, user’s rights are verified and playsms webservices are used to send SMS.
    It works like a charm !

    If you’re interested I can explain how to configure this. I think it might be interesting.

    PS : sorry for my english…



  4. I am a new programming. Yes Search the Internet for a program sms parking and occasionally met this playSMS. Can you tell what can be used for this application. If I read well.? Can I used to send Bulk SMS.? I need your help please



Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s